Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Banda opamp - dubbio teorico

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto UtenteBrunoValente, Foto Utentecarloc, Foto Utenteg.schgor

0
voti

[1] Banda opamp - dubbio teorico

Messaggioda Foto UtenteGOpamp » 17 apr 2020, 20:31

Ciao a tutti,

eccomi con un altro dei miei dubbi..

Ho un TL082 della TI. Da datasheet, Unity Gain Bandwidth = 3 MHz.. ovvero prodotto banda guadagno 3 MHz. Quindi, dal grafico della risposta in frequenza in open loop di questo operazionale, mi aspetto che a 3 MHz l'operazionale abbia un guadagno di 0 dB.
Simulazione LTSpice - scarico questo modello di TL082 fornito sul sito della TI e simulo la risposta in frequenza dell' opamp: in ingresso metto un generatore di tensione (riferito a ground) sul + dell'opamp e il - lo metto a ground. Faccio un .ac ed effettivamente, verifico che il modello si comporta come sul datasheet. A 3MHz ho 0 db.

Configurazione Voltage Follower : mi aspetto che la frequenza a -3 db sia 3MHz, e cioè che il mio opamp rispetti il prodotto banda guadagno. Invece ottengo la frequenza a -3dB è di 4.7 MHz!!!

Hmmm... penso sia un problema di modello! Allora provo a fare la stessa cosa usando l' UniversalOpamp di LTSpice e tutto, invece, funziona bene: prodotto banda guadagno xx MHz (non ricordo precisamente) ricavato in open loop = banda del Voltage follower implementato con lo stesso opamp. Tutto funziona bene! ...poi mi ricordo che UniversalOpamp è un modello IDEALE, mentre il TL082 scaricato è un modello di un componente REALE.

Sono sempre stato convinto, forse sbagliando, che la frequenza a 0dB dell open loop DEVE essere uguale alla frequenza a -3dB di un Voltage follower implementato con lo stesso opamp.

Dove sbaglio?
Avatar utente
Foto UtenteGOpamp
45 4
 
Messaggi: 49
Iscritto il: 11 dic 2018, 23:00

0
voti

[2] Re: Banda opamp - dubbio teorico

Messaggioda Foto UtenteGOpamp » 23 apr 2020, 16:40

:roll: Qualcuno che mi dia un feedback...
Avatar utente
Foto UtenteGOpamp
45 4
 
Messaggi: 49
Iscritto il: 11 dic 2018, 23:00

3
voti

[3] Re: Banda opamp - dubbio teorico

Messaggioda Foto UtenteIsidoroKZ » 23 apr 2020, 17:01

Sbagli nel non allegare il file che hai usato per fare la simulazione :-)
Il sito non accetta allegati con estensione .asc, devi presumibilmente zippare il file, e mettere anche il modello che stai usando.

Il prodotto guadagno banda e` indicato assumendo un solo polo fino a ben oltre la frequenza di crossover. In realta` ci possono essere dei poli subito dopo il crossover. Puoi evidenziare questo fatto andando a vedere la fase ad anello aperto alla frequenza di crossover, che quasi di sicuro e` minore di -90° e quindi hai un margine di fase ridotto e poli complessi coniugati.

Fai anche attenzione a come misuri il guadagno di anello ad anello aperto, a seconda del modello puo` essere difficile. Infatti per fare un'analisi .ac il simulatore fa prima una analisi dc per trovare il punto di funzionamento in continua. Se sei ad anello aperto l'operazionale potrebbe essere saturo e quello che si misura non ha senso.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
106,5k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18808
Iscritto il: 17 ott 2009, 0:00

0
voti

[4] Re: Banda opamp - dubbio teorico

Messaggioda Foto UtenteGOpamp » 24 apr 2020, 13:17

Come suggerito da Foto UtenteIsidoroKZ, allego il file necessario.

La simulazione ad anello aperto è stata fatta con questa configurazione:

I poli sono molto distanti fra di loro quindi posso ragionare sulle fasi per capire a che frequenza sono.
Il primo polo dell' opamp è a circa 15 Hz (valutato considerando la fase a -45°).
Il secondo polo dell' opamp è a 6.6 MHz circa (valutato considerando la fase a -135°).
A 0 dB la frequenza è di circa 3 MHz.
Effettivamente il secondo polo è subito dopo il crossover..

La simulazione ad anello chiuso è stata fatta con questa configurazione:

La frequenza di taglio (a -3 dB) risulta 4.7 MHz.

quindi hai un margine di fase ridotto e poli complessi coniugati.

perché complessi coniugati? Ho un polo a 15 Hz ed un altro a 6.6 MHz. Quello a 6.6 MHz mi inizia a far scendere la fase una decade prima e per questo al crossover o meno di -90°.

Fai anche attenzione a come misuri il guadagno di anello ad anello aperto, a seconda del modello puo` essere difficile. Infatti per fare un'analisi .ac il simulatore fa prima una analisi dc per trovare il punto di funzionamento in continua. Se sei ad anello aperto l'operazionale potrebbe essere saturo e quello che si misura non ha senso.

Ok. Quindi la simulazione del Voltage follower dovrebbe essere quella sensata, mentre quella fatta in open loop no.. a questo punto mi domando come fare la simulazione in open loop?
Allegati
GBW open loop vs closed loop.zip
(3.59 KiB) Scaricato 6 volte
Avatar utente
Foto UtenteGOpamp
45 4
 
Messaggi: 49
Iscritto il: 11 dic 2018, 23:00

4
voti

[5] Re: Banda opamp - dubbio teorico

Messaggioda Foto UtenteIsidoroKZ » 25 apr 2020, 13:38

Nella misura che hai fatto del guadagno ad anello aperto hai avuto fortuna perche' l'operazionale non e` saturo. Il modello di quell'operazionale ha una tensione di offset di circa 10 µV, che con un guadagno di 230000 volte da` una tensione di uscita di circa 2.6V, quindi l'operazionale e` ancora in linearita`.

Se l'offset fosse stato appena di 0.1mV l'operazionale sarebbe stato saturo e quindi la misura del guadagno ad anello aperto sarebbe stata senza senso.

Comunque mi pare che i conti (piu` o meno) tornino. Il prodotto guadagno banda a singolo polo (tralasciando il secondo), e` di 3.44 MHz circa, mentre mettendo anche il secondo polo la frequenza di crossover diventa di 3.1MHz (sempre circa). Il margine di fase e` di 64°, non di 90° come si avrebbe avuto a polo singolo.

La riduzione da 90° a 64° del margine di fase fa si` che ad anello chiuso si abbiano due poli complessi coniugati, con un fattore Q di circa 0.73, che vuol dire che nel dominio della frequenza ci sara` un leggero picco: il guadagno sale di una piccola frazione di decibel prima di scendere a -40dB/decade, quindi ci sono due poli, cosa confermata anche dalla fase che scende di 180°.

Quando ci sono due poli e il secondo polo e` vicino al crossover, bisogna studiare il circuito come sistema del secondo ordine.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
106,5k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18808
Iscritto il: 17 ott 2009, 0:00

1
voti

[6] Re: Banda opamp - dubbio teorico

Messaggioda Foto UtenteGOpamp » 25 apr 2020, 16:55

Gentilissimo Foto UtenteIsidoroKZ,

innanzitutto voglio ringraziarti per i tuoi preziosi commenti (sempre esaustivi) :D .

Nella misura che hai fatto del guadagno ad anello aperto hai avuto fortuna perche' l'operazionale non e` saturo. Il modello di quell'operazionale ha una tensione di offset di circa 10 µV, che con un guadagno di 230000 volte da` una tensione di uscita di circa 2.6V, quindi l'operazionale e` ancora in linearita`.

Non ci avevo proprio pensato.. ho imparato un'altra cosa fondamentale.

La riduzione da 90° a 64° del margine di fase fa si` che ad anello chiuso si abbiano due poli complessi coniugati, con un fattore Q di circa 0.73, che vuol dire che nel dominio della frequenza ci sara` un leggero picco: il guadagno sale di una piccola frazione di decibel prima di scendere a -40dB/decade, quindi ci sono due poli, cosa confermata anche dalla fase che scende di 180°.

Ed è quindi la presenza dei due poli complessi e coniugati la causa dei miei 4.7 MHz in anello chiuso...il picco mi "allarga la banda" del voltage follower.

Facendo il punto:
1. Il prodotto guadagno banda e` indicato assumendo un solo polo fino a ben oltre la frequenza di crossover.
2. Dato che nella realtà ci possono essere dei poli subito dopo il crossover che causano una risposta ad anello chiuso del secondo ordine, la banda dell' inseguitore di tensione realizzato con quell'opamp può essere maggiore di quella indicata dal costruttore ( quanto maggiore è il picco, maggiore sarà la banda ).
3.Inoltre, più ilsecondo polo si allontana dal crossover, più il picco si riduce e la banda dell'inseguitore di tensione si avvicina al prodotto banda guadagno indicato dal costruttore.

Giusto? :D
Avatar utente
Foto UtenteGOpamp
45 4
 
Messaggi: 49
Iscritto il: 11 dic 2018, 23:00

2
voti

[7] Re: Banda opamp - dubbio teorico

Messaggioda Foto UtenteIsidoroKZ » 25 apr 2020, 17:17

Si`, giusto. Stavo cercando qualche cosa che spiegasse i sistemi del secondo ordine a polo dominante, ma non ho trovato nulla che mi soddisfacesse. Pero` due file ci sono.

Il primo e` di Basso mentre il secondo e` di
Middlebrook e la parte che ti interessa e` da pag. 84 in avanti,
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
106,5k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 18808
Iscritto il: 17 ott 2009, 0:00

0
voti

[8] Re: Banda opamp - dubbio teorico

Messaggioda Foto UtenteGOpamp » 25 apr 2020, 18:38

Il secondo sembra molto interessante.. mi sa che leggerò anche le pagine precedenti.
Grazie ancora Foto UtenteIsidoroKZ :D
Avatar utente
Foto UtenteGOpamp
45 4
 
Messaggi: 49
Iscritto il: 11 dic 2018, 23:00


Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 52 ospiti