Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Vecchio alimentatore Macintosh

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto Utentecarloc, Foto Utenteg.schgor, Foto UtenteDirtyDeeds, Foto UtenteIsidoroKZ, Foto UtenteBrunoValente

0
voti

[1] Vecchio alimentatore Macintosh

Messaggioda Foto Utenteflip79 » 21 dic 2019, 4:28

Ciao a tutti. Sto cercando di ripare l'alimentatore di un vecchissimo Macintosh LC (1990) che aveva iniziato a "saltare" emettendo un rumore "tick tick tick..." che rallentava quando staccavo la corrente (molto buffo, sembrava proprio una ventola danneggiata).

Ho effettuato la sostituzione di 4 condensatori consigliati qui: http://maccaps.com/MacCaps/Capacitor_Re ... plies.html che effettivamente avevano rilasciato liquido. Dopo l'operazione, l'alimentatore parte ed eroga stabilmente i +5,-5 e +12 previsti. Purtroppo nel momento in cui lo chiudo, smette di funzionare e riprende ad emettere lo stesso buffo rumore (in realtà ad un volume quasi impercettibile, ma sospetto che il fatto sia legato all'assenza di carichi). Dopo un po' di prove ho verificato che il problema è legato alla messa a terra del tutto perché chiudendolo viene a crearsi il contatto tra il bordo della scheda, occupato in lunghezza dai dissipatori di calore, e lo chassis dell'alimentatore che è collegato alla terra della 220 V.

Cosa posso fare per risolvere? Sospetto che ci siano altri condensatori da sostituire, ma non so se la relazione messa a terra = malfunzionamento possa essere collegabile in qualche modo ai condensatori originali ancora da sostituire, o da qualcosa di diverso.

Grazie mille a tutti :)
Avatar utente
Foto Utenteflip79
63 5
New entry
New entry
 
Messaggi: 69
Iscritto il: 13 lug 2014, 13:42

0
voti

[2] Re: Vecchio alimentatore Macintosh

Messaggioda Foto Utenteelektronik » 21 dic 2019, 10:21

Sembrerebbe come se ci fosse un condensatore che scarica a massa
Avatar utente
Foto Utenteelektronik
4.352 4 5 7
Expert EY
Expert EY
 
Messaggi: 2305
Iscritto il: 12 mag 2015, 22:26

0
voti

[3] Re: Vecchio alimentatore Macintosh

Messaggioda Foto UtenteDarwinNE » 21 dic 2019, 12:33

A quanto pare, molti Macintosh LC o successivi dopo un po' di anni emettono un po' di rumore dall'altoparlante di sistema. In uno avevo cambiato la ventola pensando che fosse la responsabile, perché il rumore sembrava venire da lì e pensavo che le bronzine fossero andate, ma non ho risolto il problema. Mi hanno detto che forse sono i condensatori della scheda logica che iniziano ad invecchiare, ma non ho ancora provato a sostituirli.

Sei sicuro che il suono di cui parli venga dall'alimentatore e non da altre parti?
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
25,6k 5 11 13
G.Master EY
G.Master EY
 
Messaggi: 3617
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

0
voti

[4] Re: Vecchio alimentatore Macintosh

Messaggioda Foto Utenteflip79 » 21 dic 2019, 16:39

DarwinNE ha scritto:Sei sicuro che il suono di cui parli venga dall'alimentatore e non da altre parti?

Sì sì, come dicevo lo emette (fiebile) anche il solo alimentatore staccato, ed al comparire del rumore il computer si spegne, quindi purtroppo non è un problema limitato all'uscita audio :)
Avatar utente
Foto Utenteflip79
63 5
New entry
New entry
 
Messaggi: 69
Iscritto il: 13 lug 2014, 13:42

0
voti

[5] Re: Vecchio alimentatore Macintosh

Messaggioda Foto UtenteDarwinNE » 22 dic 2019, 15:26

Ma il computer funziona correttamente? Perché non è troppo strano che gli alimentatori switching facciano un po' di rumore per via degli induttori o trasformatori che vibrano leggermente. Nel qual caso, non ci sarebbe troppo da preoccuparsi.

P.S. sto giusto studiando in questo momento come programmare Macintosh di quell'era...
Follow FidoCadJ development on Twitter: https://twitter.com/davbucci
Avatar utente
Foto UtenteDarwinNE
25,6k 5 11 13
G.Master EY
G.Master EY
 
Messaggi: 3617
Iscritto il: 18 apr 2010, 9:32
Località: Grenoble - France

1
voti

[6] Re: Vecchio alimentatore Macintosh

Messaggioda Foto Utentemarioursino » 22 dic 2019, 15:27

Se hai suoni udibili e periodici in un alimentatore che non funziona, probabilmente è il soft-start che fallisce. Dopo un periodo di attesa l'alimentatore ci "riprova" fallendo periodicamente. Se il reset continua imperterrito senza manifestare comportamenti distruttivi vuol dire che c'è una protezione che interviene, magari un overcurrent perché hai un elettrolitico in corto all'uscita.

Ovviamente le possibilità sono infinite, riesci a misurare almeno l'uscita?
Avatar utente
Foto Utentemarioursino
3.767 3 9 13
G.Master EY
G.Master EY
 
Messaggi: 1360
Iscritto il: 5 dic 2009, 4:32

0
voti

[7] Re: Vecchio alimentatore Macintosh

Messaggioda Foto Utenteabusivo » 22 dic 2019, 16:20

DarwinNE ha scritto:Ma il computer funziona correttamente?...

Credo proprio di no:
flip79 ha scritto:...ed al comparire del rumore il computer si spegne...
Se quello che funziona basta non lo tocca' sennò te lassa!
Avatar utente
Foto Utenteabusivo
10,1k 4 4 8
Master
Master
 
Messaggi: 5731
Iscritto il: 16 ott 2012, 18:43
Località: L'Aquila

0
voti

[8] Re: Vecchio alimentatore Macintosh

Messaggioda Foto Utenteflip79 » 22 dic 2019, 23:07

marioursino ha scritto:Ovviamente le possibilità sono infinite, riesci a misurare almeno l'uscita?


Dunque, le uscite sono 3, e vengono correttamente erogate tenendo l'elettronica dell'alimentatore NON a contatto con lo chassis:

+5V
-5V
+12V

Un dato interessante è che, quando invece lo inserisco nello chassis, il 5V (non ricordo se il positivo o il negativo, devo ricontrollare) continua ad essere generato, mentre le altre due tensioni scendono a circa 1V, e il dissipatore attaccato agli integrati che credo siano i regolatori di tensione (?) dopo una decina di secondi sale ad una temperatura altissima, da bruciarsi se lo si tiene tra le dita. Quindi diciamo che un comportamento distruttivo c'è, sono certo che lasciandolo attaccato ancora si brucerebbe parecchia roba :)
Avatar utente
Foto Utenteflip79
63 5
New entry
New entry
 
Messaggi: 69
Iscritto il: 13 lug 2014, 13:42

0
voti

[9] Re: Vecchio alimentatore Macintosh

Messaggioda Foto Utenteclaudiocedrone » 23 dic 2019, 1:03

Prova a sostituire gli isolatori dei componenti sul dissipatore.
"Non farei mai parte di un club che accettasse la mia iscrizione" (G. Marx)
Avatar utente
Foto Utenteclaudiocedrone
15,2k 4 6 9
Master EY
Master EY
 
Messaggi: 10626
Iscritto il: 18 gen 2012, 13:36

0
voti

[10] Re: Vecchio alimentatore Macintosh

Messaggioda Foto Utenteflip79 » 23 dic 2019, 1:11

Isolatori? Scusami non credo di aver capito.
Avatar utente
Foto Utenteflip79
63 5
New entry
New entry
 
Messaggi: 69
Iscritto il: 13 lug 2014, 13:42

Prossimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Google [Bot], MSN [Bot] e 79 ospiti