Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Riparazione switching: FET che salta ad ogni accensione

Elettronica lineare e digitale: didattica ed applicazioni

Moderatori: Foto UtenteBrunoValente, Foto UtenteDirtyDeeds, Foto Utentecarloc, Foto UtenteIsidoroKZ, Foto Utenteg.schgor

0
voti

[31] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto UtenteBrunoValente » 18 nov 2014, 11:43

Prima di fare la misura, oltre a staccare il pin 10, togli il mosfet e fai anche un ponte su C940, cioè mettilo in cortocircuito.

Se la tensione tra 8 e 7 (o tra 8 e 13) è davvero così ballerina controlla meglio C925 o al limite, se hai dubbi, montane un altro di valore simile in parallelo e vedi se diventa stabile.

Controlla pure il valore di R926 staccandola almeno da un lato e la continuità dei quattro avvolgimenti di T906 (possibilmente smontandolo) che devono presentare resistenza bassissima, controlla pure che siano ben isolati tra loro (portata 20Mohm).
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6275
Iscritto il: 8 mag 2007, 14:48

0
voti

[32] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto Utenteauato » 18 nov 2014, 21:43

Ciao Bruno, sto leggendo solo ora questo tuo ultimo post. Nel frattempo avevo già fatto delle prove con un tester ICE. Confermo quelle tensioni così ballerine. Guarda qui:

http://youtu.be/jWJWjYZjts8

Dopo aver fatto il video sopra ma comunque prima di scrivere questo messaggio ho anche escluso il mosfet, cortocircuitato C940 e posto in parallelo un elettrolitico simile a C925 ma la tensione rimane "ballerina" in egual modo (anzi i valori di escursione si sono anche alzati di parecchio e tra pin 12 e 13 dell'integrato l'escursione è ora tra 2 e 30V).

Appena posso faccio anche le prove di R926 e T906 che mi dici e aggiorno il thread.

Grazie
Avatar utente
Foto Utenteauato
41 4
New entry
New entry
 
Messaggi: 81
Iscritto il: 9 ott 2012, 9:17

0
voti

[33] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto UtenteBrunoValente » 18 nov 2014, 22:13

La tensione tra 12 e 13 non dovrebbe superare i 14-15V e nelle condizioni in cui stai misurando (mosfet sconnesso) dovrebbe essere oscillante, lo stesso la tensione ai capi di C925 dovrebbe oscillare a dente di sega tra 7 e 15V con un periodo di qualche frazione di secondo, forse 0.3-0.4s, quindi non dovresti leggere tensioni superiori a 15V.
Direi che faresti bene a procurarti un trasf. di isolamento e ad andarci a guardare con un oscilloscopio.
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6275
Iscritto il: 8 mag 2007, 14:48

0
voti

[34] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto Utenteauato » 18 nov 2014, 23:41

Ma oscillava anche prima che staccassi il mosfet (funzionante) ed era solo col pin 10 appeso.

Prima ho detto una cavolata... tra pin 12 e 13 c'erano picchi di 4V che poi son diventati picchi di quasi 6V quando ho inserito in parallelo il secondo condensatore elettrolitico da 100uF a C925. Per la cronaca... quando ho inserito questo secondo condensatore in parallelo, oltre ad alzarsi la tensione, si è anche dimezzata la velocità di oscillazione, giustamente.

Ad ogni modo ho trovato in scantinato un vecchio trasformatore abbassatore 220-110V 1300VA :lol:
Dovrebbe funzionare... e così potrei alimentarlo a 110V.
Avatar utente
Foto Utenteauato
41 4
New entry
New entry
 
Messaggi: 81
Iscritto il: 9 ott 2012, 9:17

0
voti

[35] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto UtenteBrunoValente » 19 nov 2014, 22:38

Ottimo il trasformatore, occhio però che non sia un autotrasformatore perché non sarebbe isolato.
auato ha scritto:Ma oscillava anche prima che staccassi il mosfet (funzionante) ed era solo col pin 10 appeso.

Sì, è la stessa cosa, comunque il mosfet era spento
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6275
Iscritto il: 8 mag 2007, 14:48

0
voti

[36] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto UtenteBrunoValente » 20 nov 2014, 16:57

Con cosa stai rimpiazzando il diodo CR907? Sei sicuro di montarlo con il verso giusto?
Ti faccio queste domande perché il circuito dovrebbe essere efficacemente protetto da sovracorrenti dovute a qualsiasi malfunzionamento: U930 con gli ingressi 15 e 16 dovrebbe regolare le commutazioni del mosfet per evitare che la caduta su R907 superi 0.2V e cioè che la corrente al carico superi 1A.
Se però CR907 fosse in perdita o fosse montato al contrario allora la caduta su R907 non aumenterebbe e quindi il controllo di massima corrente non interverrebbe.
E' importante che il diodo sia veloce e in grado di sopportare le tensioni e le correnti in gioco..potrebbe essere che la prima volta si sia rotto per invecchiamento o per cause fisiologiche e che tu lo stia rimpiazzando con un tipo non idoneo.
Stesso discorso vale per il mosfet, con cosa lo stai rimpiazzando?
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6275
Iscritto il: 8 mag 2007, 14:48

0
voti

[37] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto Utenteauato » 20 nov 2014, 23:27

Bruno, proprio oggi mi passava per la mente di farti questa domanda sulla correttezza di Mosfet e diodo che sto utilizzando... me ne sarei dimenticato se non avessi letto ora qui.
Sto utilizzando dei comunissimi 1N4007 per CR907 ed ho provato con degli IRF840 prima e IRF730 ora per il Mosfet (ne avrò cambiati una decina).
Il diodo non può essere in perdita perché, come scrivevo qualche riga sopra, insieme al mosfet ne avrò cambiati in quantità. La polarità con cui lo monto è giusta, ovvero catodo verso R907 e/o E907. Ho provato anche mettendone due in parallelo.
Ultima modifica di Foto Utentemarco438 il 7 dic 2014, 13:02, modificato 1 volta in totale.
Motivazione: Eliminato quoting inutile; usa il tasto rispondi.
Avatar utente
Foto Utenteauato
41 4
New entry
New entry
 
Messaggi: 81
Iscritto il: 9 ott 2012, 9:17

0
voti

[38] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto Utenteauato » 20 nov 2014, 23:42

Ad ogni modo ho messo in funzione il trasformatore a 110 che è di isolamento e non è un autotrasformatore. Nei giorni scorsi ho controllato quasi tutti i componenti della sezione pre-regolatore dissaldando una terminale per ciascuno di essi e misurandoli. Ho poi proceduto alla sostituzione di tutti i condensatori presenti in questa sezione (compreso il grosso C906) e dello zener VR925. Fatto tutto ciò, credevo di avere qualche barlume di speranza ma, per la solita smania e non curanza, non avendo acceso alcun cero a qualche Santo protettore :D :D :D , come avrei dovuto immaginare, è saltato l'ennesimo Mosfet con diodo e fusibile (anche a 110V) #-o Dopo questo ennesimo tentativo da fatalista, sono rinsavito e mi sono ricordato che l'elettronica, come la matematica, non è un'opinione :roll:
Allora mi sono armato di oscilloscopio con il coccodrillo di massa collegato al riferimeto TP950 e facendo qualche benedetta misura intorno a U930, naturalmente con Mosfet scollegato.

Ecco un breve video di ciò che ho misurato ed in cui commento a voce i passaggi:

http://youtu.be/-ayVlqP5_jw
Avatar utente
Foto Utenteauato
41 4
New entry
New entry
 
Messaggi: 81
Iscritto il: 9 ott 2012, 9:17

0
voti

[39] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto UtenteBrunoValente » 21 nov 2014, 10:55

Ferma, ferma!! Lo divevo che il diodo in qualche modo doveva entrarci! l'1N4007 non va assolutamente bene, è lui che si distrugge immediatamente e che si tira dietro anche il mosfet, devi utilizzare un diodo veloce, l'1N4007 funziona bene solo a 50Hz e non è assolutamente adatto per commutare ad alta frequenza.
Devi montare un diodo tipo questo

I mosfet dovrebbero andare bene entrambi, forse il 730 è più adatto.

Ottimo il video: sembrerebbe tutto ok :ok:
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6275
Iscritto il: 8 mag 2007, 14:48

0
voti

[40] Re: Riparazione switching: FET che salta ad ogni accensione

Messaggioda Foto UtenteBrunoValente » 21 nov 2014, 11:24

..Vedo che hai un laboratorio ben attrezzato, posso chiederti cosa fai?
Avatar utente
Foto UtenteBrunoValente
32,3k 7 10 13
G.Master EY
G.Master EY
 
Messaggi: 6275
Iscritto il: 8 mag 2007, 14:48

PrecedenteProssimo

Torna a Elettronica generale

Chi c’è in linea

Visitano il forum: Nessuno e 25 ospiti